<!doctype html><html lang="en-GB" prefix="og: http://ogp.me/ns#"><head> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  ga('create', 'UA-988171-75', 'auto');
  ga('send', 'pageview');</script> <meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1"><link rel="profile" href="http://gmpg.org/xfn/11"><link href="https://fonts.googleapis.com/css?family=Roboto+Condensed:300,400" rel="stylesheet"><link type="text/css" media="all" href="https://silicondales.com/wp-content/cache/autoptimize/css/autoptimize_a7490ce7f40a67ef26842e79d299f26a.css" rel="stylesheet" /><title>WordPress editing - keyboard shortcuts - Silicon Dales</title><link rel="canonical" href="https://silicondales.com/tutorials/wordpress-tutorials/wordpress-editing-keyboard-shortcuts/" /><link rel="publisher" href="https://plus.google.com/+Silicondales/"/><meta property="og:locale" content="en_GB" /><meta property="og:type" content="article" /><meta property="og:title" content="WordPress editing - keyboard shortcuts - Silicon Dales" /><meta property="og:description" content="Table of Contents Editor Keyboard ShortcutsCtrl + keyAlt + Shift + keyFormatting ShortcutsKeyboard Shortcuts for CommentsActivating Keyboard ShortcutsThe Meaning of SelectedUsing Keyboard Shortcuts to Navigate CommentsUsing Keyboard Shortcuts to Perform Actions on CommentsBulk Actions (Last Updated On: February 5, 2018)Over the years, we published a lot of WordPress (and other) Tutorials, and often its the &hellip;" /><meta property="og:url" content="https://silicondales.com/tutorials/wordpress-tutorials/wordpress-editing-keyboard-shortcuts/" /><meta property="og:site_name" content="Silicon Dales" /><meta property="article:publisher" content="https://www.facebook.com/SiliconDales" /><meta property="article:tag" content="keyboard" /><meta property="article:tag" content="shortcuts" /><meta property="article:section" content="WordPress Tutorials" /><meta property="article:published_time" content="2018-02-05T17:04:43+00:00" /><meta property="article:modified_time" content="2018-02-05T17:10:04+00:00" /><meta property="og:updated_time" content="2018-02-05T17:10:04+00:00" /><meta property="og:image" content="https://silicondales.com/wp-content/uploads/2015/12/silicon-dales-logo-2016-website-header-dimensions.png" /><meta property="og:image:secure_url" content="https://silicondales.com/wp-content/uploads/2015/12/silicon-dales-logo-2016-website-header-dimensions.png" /><meta name="twitter:card" content="summary_large_image" /><meta name="twitter:description" content="Table of Contents Editor Keyboard ShortcutsCtrl + keyAlt + Shift + keyFormatting ShortcutsKeyboard Shortcuts for CommentsActivating Keyboard ShortcutsThe Meaning of SelectedUsing Keyboard Shortcuts to Navigate CommentsUsing Keyboard Shortcuts to Perform Actions on CommentsBulk Actions (Last Updated On: February 5, 2018)Over the years, we published a lot of WordPress (and other) Tutorials, and often its the [&hellip;]" /><meta name="twitter:title" content="WordPress editing - keyboard shortcuts - Silicon Dales" /><meta name="twitter:site" content="@silicondales" /><meta name="twitter:image" content="https://silicondales.com/wp-content/uploads/2017/02/wordpress-logo-long-web-optimized.jpg" /><meta name="twitter:creator" content="@silicondales" /> <script type='application/ld+json'>{"@context":"http:\/\/schema.org","@type":"WebSite","@id":"#website","url":"https:\/\/silicondales.com\/","name":"Silicon Dales","potentialAction":{"@type":"SearchAction","target":"https:\/\/silicondales.com\/?s={search_term_string}","query-input":"required name=search_term_string"}}</script> <link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Silicon Dales &raquo; Feed" href="https://silicondales.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Silicon Dales &raquo; Comments Feed" href="https://silicondales.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Silicon Dales &raquo; WordPress editing &#8211; keyboard shortcuts Comments Feed" href="https://silicondales.com/tutorials/wordpress-tutorials/wordpress-editing-keyboard-shortcuts/feed/" /><link rel='stylesheet' id='tf-google-webfont-dosis-css'  href='//fonts.googleapis.com/css?family=Dosis%3Ainherit%2C400&#038;subset=latin%2Clatin-ext&#038;ver=232ad61019f82b7b8c59cf11f69c2039' type='text/css' media='all' /><link rel='https://api.w.org/' href='https://silicondales.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://silicondales.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://silicondales.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://silicondales.com/?p=60981' /><link rel="alternate" type="application/json+oembed" href="https://silicondales.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsilicondales.com%2Ftutorials%2Fwordpress-tutorials%2Fwordpress-editing-keyboard-shortcuts%2F" /><link rel="alternate" type="text/xml+oembed" href="https://silicondales.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fsilicondales.com%2Ftutorials%2Fwordpress-tutorials%2Fwordpress-editing-keyboard-shortcuts%2F&#038;format=xml" /> <script type="text/javascript">(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//silicondales.com/?wordfence_lh=1&hid=83C4E460A5B76BCBE63F56A1F6A2D0F7');</script><link rel="pingback" href="https://silicondales.com/xmlrpc.php"><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://silicondales.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--> <noscript><style type="text/css">.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-60981 single-format-standard wp-custom-logo locale-en-gb wpb-js-composer js-comp-ver-5.4.5 vc_responsive mob-menu-slideout"><div id="page" class="site"> <a class="skip-link screen-reader-text" href="#content">Skip to content</a><header id="masthead" class="site-header"><div class="header-widther"><div class="site-branding"> <a href="https://silicondales.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="850" height="200" src="https://silicondales.com/wp-content/uploads/2017/12/cropped-silicon-dales-logo-2016.png" class="custom-logo" alt="Silicon Dales" itemprop="logo" srcset="https://silicondales.com/wp-content/uploads/2017/12/cropped-silicon-dales-logo-2016.png 850w, https://silicondales.com/wp-content/uploads/2017/12/cropped-silicon-dales-logo-2016-300x71.png 300w, https://silicondales.com/wp-content/uploads/2017/12/cropped-silicon-dales-logo-2016-768x181.png 768w" sizes="(max-width: 850px) 100vw, 850px" /></a><p class="site-title"><a href="https://silicondales.com/" rel="home">Silicon Dales</a></p><p class="site-description">Cloud &amp; IT Services for Business</p></div><nav id="site-navigation" class="main-navigation"><div class="menu-primary-menu-container"><ul id="primary-menu" class="menu"><li id="menu-item-59617" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59617"><a href="https://silicondales.com/agencies/">Agencies</a></li><li id="menu-item-59610" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59610"><a href="https://silicondales.com/magazine/">Magazine</a></li><li id="menu-item-59607" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59607"><a href="https://silicondales.com/about-us/">About</a></li><li id="menu-item-59608" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59608"><a href="https://silicondales.com/about-us/contact-us/">Contact</a></li><li id="menu-item-59953" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59953"><a href="https://silicondales.com/services/">Services</a></li></ul></div></nav></div></header><div id="content" class="site-content"><div id="primary" class="content-area"><main id="main" class="site-main"><article id="post-60981" class="post-60981 post type-post status-publish format-standard has-post-thumbnail hentry category-wordpress-tutorials tag-keyboard tag-shortcuts"><header class="entry-header"><h1 class="entry-title">WordPress editing &#8211; keyboard shortcuts</h1><p id="breadcrumbs"><span xmlns:v="http://rdf.data-vocabulary.org/#"><span typeof="v:Breadcrumb"><a href="https://silicondales.com/" rel="v:url" property="v:title">Home</a> | <span rel="v:child" typeof="v:Breadcrumb"><a href="https://silicondales.com/tutorials/" rel="v:url" property="v:title">Tutorials</a> | <span rel="v:child" typeof="v:Breadcrumb"><a href="https://silicondales.com/tutorials/wordpress-tutorials/" rel="v:url" property="v:title">WordPress Tutorials</a> | <span class="breadcrumb_last">WordPress editing &#8211; keyboard shortcuts</span></span></span></span></span></p><div class="entry-meta"> <span class="posted-on">Posted on <a href="https://silicondales.com/tutorials/wordpress-tutorials/wordpress-editing-keyboard-shortcuts/" rel="bookmark"><time class="entry-date published" datetime="2018-02-05T17:04:43+00:00">February 5, 2018</time><time class="updated" datetime="2018-02-05T17:10:04+00:00">February 5, 2018</time></a></span><span class="byline"> by <span class="author vcard"><a class="url fn n" href="https://silicondales.com/author/robin-scott/">Robin Scott</a></span></span></div></header><div class="entry-content"><div class="featured-post-image" style="width:33%;float:right;"> <img title="WordPress editing &#8211; keyboard shortcuts" alt="WordPress editing &#8211; keyboard shortcuts featured image" class="wp-post-image" src="https://silicondales.com/wp-content/uploads/2017/02/wordpress-logo-long-web-optimized.jpg" style="width:100%; height:auto;"></div><div id="ez-toc-container" class="counter-hierarchy counter-decimal ez-toc-grey"><div class="ez-toc-title-container"><p class="ez-toc-title">Table of Contents</p> <span class="ez-toc-title-toggle"><a class="pull-right btn btn-xs btn-default ez-toc-toggle"><i class="glyphicon ez-toc-icon-toggle"></i></a></span></div><ul class="ez-toc-list"><li><a href="#Editor_Keyboard_Shortcuts" title="Editor Keyboard Shortcuts">Editor Keyboard Shortcuts</a><ul><li><a href="#Ctrl_key" title="Ctrl + key">Ctrl + key</a></li><li><a href="#Alt_Shift_key" title="Alt + Shift + key">Alt + Shift + key</a></li><li><a href="#Formatting_Shortcuts" title="Formatting Shortcuts">Formatting Shortcuts</a></li></ul></li><li><a href="#Keyboard_Shortcuts_for_Comments" title="Keyboard Shortcuts for Comments">Keyboard Shortcuts for Comments</a><ul><li><a href="#Activating_Keyboard_Shortcuts" title="Activating Keyboard Shortcuts">Activating Keyboard Shortcuts</a></li><li><a href="#The_Meaning_of_Selected" title="The Meaning of Selected">The Meaning of Selected</a></li><li><a href="#Using_Keyboard_Shortcuts_to_Navigate_Comments" title="Using Keyboard Shortcuts to Navigate Comments">Using Keyboard Shortcuts to Navigate Comments</a></li><li><a href="#Using_Keyboard_Shortcuts_to_Perform_Actions_on_Comments" title="Using Keyboard Shortcuts to Perform Actions on Comments">Using Keyboard Shortcuts to Perform Actions on Comments</a></li><li><a href="#Bulk_Actions" title="Bulk Actions">Bulk Actions</a></li></ul></li></ul></div> <span style="font-style:italic; font-weight:bold;text-align:center;">(Last Updated On: February 5, 2018)</span><p>Over the years, we published a lot of WordPress (and other) Tutorials, and often its the simplest of them which are the most used. We publish tutorials for our clients &#8211; so we can point them at the link, and know it will still be there in a few months or years time &#8211; and also for the wider web, as, well, sharing is caring&#8230;</p><p>With the WordPress editor up for changes in the forthcoming months (this is great news, and the Gutenberg project is one you should keep ahead of if WordPress is in your network of sites, for sure), we&#8217;re publishing some items about the &#8220;traditional&#8221; WordPress editor, here, for our clients who&#8217;ll be sticking with it for the time being.</p><p>So below are the keyboard shortcuts you can use to make various things happen while editing away in the post-new.php pages of your WordPress website!</p><p>The below came from the WordPress Codex &#8211; which I highly recommend you check out &#8211; but is being forked and edited here, for future reference in relation to the WordPress visual editor. Any errors are ours!</p><h2><span class="ez-toc-section" id="Editor_Keyboard_Shortcuts"><span id="Editor_Shortcuts" class="mw-headline">Editor Keyboard Shortcuts</span></span></h2><p>In the WordPress visual editor you can use a combination of keys to do things that normally need a mouse, trackpad or other input device. Rather than reaching for your mouse to click on the toolbar, you can use the following keyboard shortcuts:</p><p>Windows or Linux use &#8220;Ctrl + letter&#8221;. For a Mac, use &#8220;Command (⌘) + letter&#8221;.</p><h3><span class="ez-toc-section" id="Ctrl_key"><span id="Ctrl_.2B_key" class="mw-headline">Ctrl + key</span></span></h3><table><tbody><tr style="text-align:left;"><th>Letter</th><th>Action</th></tr><tr><td>c</td><td>Copy</td></tr><tr><td>v</td><td>Paste</td></tr><tr><td>a</td><td>Select all</td></tr><tr><td>x</td><td>Cut</td></tr><tr><td>z</td><td>Undo</td></tr><tr><td>y</td><td>Redo</td></tr><tr><td>b</td><td>Bold</td></tr><tr><td>i</td><td>Italic</td></tr><tr><td>u</td><td>Underline</td></tr><tr><td>k</td><td>Insert/edit link</td></tr></tbody></table><h3><span class="ez-toc-section" id="Alt_Shift_key">Alt + Shift + key</span></h3><p>The following shortcuts use a different key combination: Windows/Linux: &#8220;Alt + Shift (⇧) + letter&#8221;. Mac: &#8220;Ctrl + Option (alt ⌥) + letter&#8221;. (Macs running any WordPress version below 4.2 use &#8220;Alt + Shift (⇧) + letter&#8221;).</p><table><tbody><tr style="text-align:left;"><th>Letter</th><th>Action</th></tr><tr><td>n</td><td>Check Spelling (This requires a plugin.)</td></tr><tr><td>l</td><td>Align Left</td></tr><tr><td>j</td><td>Justify Text</td></tr><tr><td>c</td><td>Align Center</td></tr><tr><td>d</td><td>Strikethrough</td></tr><tr><td>r</td><td>Align Right</td></tr><tr><td>u</td><td>• List</td></tr><tr><td>a</td><td>Insert link</td></tr><tr><td>o</td><td>1. List</td></tr><tr><td>s</td><td>Remove link</td></tr><tr><td>q</td><td>Quote</td></tr><tr><td>m</td><td>Insert Image</td></tr><tr><td>w</td><td>Distraction Free Writing mode</td></tr><tr><td>t</td><td>Insert More Tag</td></tr><tr><td>p</td><td>Insert Page Break tag</td></tr><tr><td>h</td><td>Help</td></tr><tr><td>x</td><td>Add/remove code tag</td></tr><tr><td>1</td><td>Heading 1</td></tr><tr><td>2</td><td>Heading 2</td></tr><tr><td>3</td><td>Heading 3</td></tr><tr><td>4</td><td>Heading 4</td></tr><tr><td>5</td><td>Heading 5</td></tr><tr><td>6</td><td>Heading 6</td></tr><tr><td>9</td><td>Address</td></tr></tbody></table><h3><span class="ez-toc-section" id="Formatting_Shortcuts">Formatting Shortcuts</span></h3><p>Formatting Shortcuts while using visual editor (Since <a title="Version 4.3" href="https://codex.wordpress.org/Version_4.3">Version 4.3</a>)</p><table><tbody><tr style="text-align:left;"><th>Letter</th><th>Action</th></tr><tr><td>*</td><td>Start an unordered list</td></tr><tr><td>&#8211;</td><td>Start an unordered list</td></tr><tr><td>1.</td><td>Start an ordered list</td></tr><tr><td>1)</td><td>Start an ordered list</td></tr><tr><td>##</td><td>H2</td></tr><tr><td>###</td><td>H3</td></tr><tr><td>####</td><td>H4</td></tr><tr><td>#####</td><td>H5</td></tr><tr><td>######</td><td>H6</td></tr><tr><td>&gt;</td><td>transform text into blockquote</td></tr><tr><td>&#8212;</td><td>horizontal line</td></tr><tr><td><code>`..`</code></td><td>transform text into code block</td></tr></tbody></table><h2><span class="ez-toc-section" id="Keyboard_Shortcuts_for_Comments">Keyboard Shortcuts for Comments</span></h2><p>Beginning with <a title="Version 2.7" href="https://codex.wordpress.org/Version_2.7">WordPress Version 2.7</a>, the ability to use keyboard shortcuts to browse and moderate comments was introduced. These keyboard shortcuts are designed to save time by allowing you to rapidly navigate and perform actions on comments. If your blog gets a large number of comments, you will find these shortcuts especially useful.</p><h3><span class="ez-toc-section" id="Activating_Keyboard_Shortcuts"><span id="Activating_Keyboard_Shortcuts" class="mw-headline">Activating Keyboard Shortcuts</span></span></h3><p>Keyboard shortcuts are enabled on a per-user setting, and can be turned on by visiting the Profile panel in <a class="mw-redirect" title="Administration Panels" href="https://codex.wordpress.org/Administration_Panels">Administration</a> &gt; <a class="mw-redirect" title="Administration Panels" href="https://codex.wordpress.org/Administration_Panels#Your_Profile">Users</a> &gt; <a class="mw-redirect" title="Users Your Profile SubPanel" href="https://codex.wordpress.org/Users_Your_Profile_SubPanel">Your Profile</a>. Check the <a class="mw-redirect" title="Users Your Profile SubPanel" href="https://codex.wordpress.org/Users_Your_Profile_SubPanel#Personal_Options">Keyboard Shortcuts</a> checkbox to enable keyboard shortcuts for comment moderation.</p><p>Please note, the keyboard shortcuts are designed to use both hands, simultaneously, on a QWERTY style keyboard layout.</p><h3><span class="ez-toc-section" id="The_Meaning_of_Selected">The Meaning of Selected</span></h3><p>The keyboard shortcuts are used for navigation and for actions. For any action to affect a comment, that comment must be first <b>selected</b>. The comment that is considered <b>selected</b> is indicated with a light-blue background. By default, no comment is selected, so, you will need to press either the letter <b>j</b> key, or letter <b>k</b> key, to start navigating.</p><h3><span class="ez-toc-section" id="Using_Keyboard_Shortcuts_to_Navigate_Comments"><span id="Using_Keyboard_Shortcuts_to_Navigate_Comments" class="mw-headline">Using Keyboard Shortcuts to Navigate Comments</span></span></h3><p>Navigating comments is accomplished with the <b>j</b> and <b>k</b> keys. When you first visit the Comments page, no comments is selected, so, first press the letter <b>j</b>, or the letter <b>k</b>, to select the first comment. After that, just press the letter <b>j</b> to move the select to the next comment.</p><ul><li>Pressing <b>j</b> moves the current selection (light-blue background) down.</li><li>Pressing <b>k</b> moves the current selection (light-blue background) up.</li></ul><p>Note that if you come to the bottom of a page of comments and press <b>j</b> again, you will be taken to the next page and the first comment of that next page will be selected. Likewise, pressing <b>k</b> at the top of a comment page will zoom you to the previous page, selecting the comment at the bottom of that previous page. This makes it very easy to navigate through a long list of comments to perform the necessary actions.</p><h3><span class="ez-toc-section" id="Using_Keyboard_Shortcuts_to_Perform_Actions_on_Comments">Using Keyboard Shortcuts to Perform Actions on Comments</span></h3><p>For one of these actions to affect a comment, make sure the comment is first selected (see above).</p><ul><li>Pressing <b>a</b> approves the currently selected comment.</li><li>Pressing <b>s</b> marks the current comment as spam.</li><li>Pressing <b>d</b> moves the comment to the trash (WordPress 2.9) or deletes the current comment.</li><li>Pressing <b>z</b> restores the current comment from the trash or activates the Undo when that row is selected.</li><li>Pressing <b>u</b> unapproves the currently selected comment, placing it back into moderation.</li><li>Pressing <b>r</b> initiates an inline reply to the current comment (you can press <b>Esc</b> to cancel the reply).</li><li>Pressing <b>q</b> activates &#8220;Quick Edit&#8221; which allows for rapid inline editing of the current comment.</li><li>Pressing <b>e</b> navigates to the edit screen for the current comment.</li></ul><h3><span class="ez-toc-section" id="Bulk_Actions">Bulk Actions</span></h3><p>You can also perform an action on multiple comments at once. First, you&#8217;ll need to select the comments for the bulk action, using the <b>x</b>key to check the checkbox for the currently selected comment. <b>Shift-x</b> can be used to toggle the checkboxes, inverting their state. Once you have some comments checked:</p><ul><li>Pressing <b>Shift-a</b> approves the checked comments.</li><li>Pressing <b>Shift-s</b> marks the checked comments as spam.</li><li>Pressing <b>Shift-d</b> deletes the checked comments.</li><li>Pressing <b>Shift-u</b> unapproves the checked comments.</li><li>Pressing <b>Shift-t</b> moves the checked comments to the Trash.</li><li>Pressing <b>Shift-z</b> restores the checked comments from the Trash.</li></ul></div><footer class="entry-footer"> <span class="cat-links">Posted in <a href="https://silicondales.com/tutorials/wordpress-tutorials/" rel="category tag">WordPress Tutorials</a></span><span class="tags-links">Tagged <a href="https://silicondales.com/tag/keyboard/" rel="tag">keyboard</a>, <a href="https://silicondales.com/tag/shortcuts/" rel="tag">shortcuts</a></span></footer></article><div id="comments" class="comments-area"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/tutorials/wordpress-tutorials/wordpress-editing-keyboard-shortcuts/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://silicondales.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> Required fields are marked <span class="required">*</span></p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" maxlength="65525" aria-required="true" required="required"></textarea></p><p class="comment-form-author"><label for="author">Name <span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" maxlength="245" aria-required='true' required='required' /></p><p class="comment-form-email"><label for="email">Email <span class="required">*</span></label> <input id="email" name="email" type="email" value="" size="30" maxlength="100" aria-describedby="email-notes" aria-required='true' required='required' /></p><p class="comment-form-url"><label for="url">Website</label> <input id="url" name="url" type="url" value="" size="30" maxlength="200" /></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='60981' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="2215a71d5c" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="138"/></p></form></div></div></main></div><aside id="secondary" class="widget-area"><section id="search-5" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://silicondales.com/"> <label> <span class="screen-reader-text">Search for:</span> <input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" /> </label> <input type="submit" class="search-submit" value="Search" /></form></section><section id="nav_menu-3" class="widget widget_nav_menu"><h2 class="widget-title">Services</h2><div class="menu-services-container"><ul id="menu-services" class="menu"><li id="menu-item-51439" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51439"><a href="https://silicondales.com/services/web-development/wordpress-experts/">WordPress Expert Developers</a></li><li id="menu-item-51440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51440"><a href="https://silicondales.com/services/web-development/woocommerce-experts/">Expert WooCommerce Developers</a></li><li id="menu-item-51436" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51436"><a href="https://silicondales.com/services/email/managed-google-work/">Secure Email</a></li><li id="menu-item-51441" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51441"><a href="https://silicondales.com/services/email/vpn-for-business/">VPN for Business</a></li><li id="menu-item-60205" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-60205"><a href="https://silicondales.com/services/consultancy/">Consultancy</a></li><li id="menu-item-59934" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-59934"><a href="https://silicondales.com/services/">More Services</a></li></ul></div></section><section id="categories-4" class="widget widget_categories"><h2 class="widget-title">Magazine Categories</h2><form action="https://silicondales.com" method="get"><label class="screen-reader-text" for="cat">Magazine Categories</label><select  name='cat' id='cat' class='postform' ><option value='-1'>Select Category</option><option class="level-0" value="11">Android Tutorials</option><option class="level-0" value="12">AWS EC2 Tutorials</option><option class="level-0" value="2267">Case Studies</option><option class="level-0" value="13">Desktop Tutorials</option><option class="level-0" value="2182">G Suite Tutorials</option><option class="level-0" value="2116">iPhone Tutorials</option><option class="level-0" value="2321">Linux Tutorials</option><option class="level-0" value="14">Magento Tutorials</option><option class="level-0" value="2160">Mailchimp Tutorials</option><option class="level-0" value="15">MySQL Tutorials</option><option class="level-0" value="6">News from Silicon Dales</option><option class="level-0" value="4693">Plesk Tutorials</option><option class="level-0" value="4377">Reviews</option><option class="level-0" value="2133">SEO Tutorials</option><option class="level-0" value="4776">Stripe Tutorials</option><option class="level-0" value="9">Tutorials</option><option class="level-0" value="4378">WooCommerce Extensions</option><option class="level-0" value="2327">WooCommerce Tutorials</option><option class="level-0" value="10">WordPress Tutorials</option> </select></form> <script type='text/javascript'>(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();</script> </section><section id="text-3" class="widget widget_text"><h2 class="widget-title">Hire us via Codeable</h2><div class="textwidget"><a href="https://codeable.io/developers/silicon-dales/?ref=EGTlB" rel="nofollow"><img src="data:image/gif;base64,R0lGODdhAQABAPAAAP///wAAACwAAAAAAQABAEACAkQBADs=" data-lazy-src="https://silicondales.com/wp-content/uploads/2016/10/codeable-badge.jpg" height="128px" width="340px" alt="Codeable badge" title="Hire Silicon Dales on Codeable" /><noscript><img src="https://silicondales.com/wp-content/uploads/2016/10/codeable-badge.jpg" height="128px" width="340px" alt="Codeable badge" title="Hire Silicon Dales on Codeable" /></noscript></a></div></section><section id="recent-comments-3" class="widget widget_recent_comments"><h2 class="widget-title">Recent Comments</h2><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link"><a href='https://silicondales.com/' rel='external nofollow' class='url'>Robin Scott</a></span> on <a href="https://silicondales.com/news-from-silicon-dales/silicon-dales-parent-becomes-silicon-dales-ltd/#comment-438723">Silicon Dales Parent Becomes Silicon Dales Ltd</a></li><li class="recentcomments"><span class="comment-author-link"><a href='https://www.imiwebdesigns.com/' rel='external nofollow' class='url'>Marc</a></span> on <a href="https://silicondales.com/tutorials/linux-tutorials/troubleshooting-mailgun-550-sender-no-aaaa-mx-dns-records/#comment-438645">Troubleshooting Mailgun &#8220;550 Sender has no A, AAAA, or MX DNS records.&#8221;</a></li><li class="recentcomments"><span class="comment-author-link">Rudi</span> on <a href="https://silicondales.com/tutorials/android-tutorials/fix-master-sync-disabled-samsung-galaxy-s4-s5-s6-s7/#comment-438488">Fix Master Sync Disabled in Samsung Galaxy s4, s5, s6 or s7</a></li><li class="recentcomments"><span class="comment-author-link">Nishith</span> on <a href="https://silicondales.com/tutorials/aws-ec2-tutorials/setup-ftp-sftp-aws-ec2-instance/#comment-438360">How to Setup FTP (FTPS (not SFTP)) on an AWS EC2 Instance</a></li><li class="recentcomments"><span class="comment-author-link">Fran</span> on <a href="https://silicondales.com/tutorials/remove-people-also-like-section-facebook-page/#comment-438351">How to remove &#8220;People Also Like&#8221; section from a Facebook Page</a></li></ul></section><section id="tag_cloud-2" class="widget widget_tag_cloud"><h2 class="widget-title">Popular Tags</h2><div class="tagcloud"><a href="https://silicondales.com/tag/amazon/" class="tag-cloud-link tag-link-66 tag-link-position-1" style="font-size: 9.1304347826087pt;" aria-label="Amazon (11 items)">Amazon</a> <a href="https://silicondales.com/tag/amazon-web-services/" class="tag-cloud-link tag-link-71 tag-link-position-2" style="font-size: 11.391304347826pt;" aria-label="Amazon Web Services (21 items)">Amazon Web Services</a> <a href="https://silicondales.com/tag/apache/" class="tag-cloud-link tag-link-82 tag-link-position-3" style="font-size: 9.3913043478261pt;" aria-label="Apache (12 items)">Apache</a> <a href="https://silicondales.com/tag/australia/" class="tag-cloud-link tag-link-111 tag-link-position-4" style="font-size: 9.1304347826087pt;" aria-label="Australia (11 items)">Australia</a> <a href="https://silicondales.com/tag/aws/" class="tag-cloud-link tag-link-118 tag-link-position-5" style="font-size: 10.434782608696pt;" aria-label="AWS (16 items)">AWS</a> <a href="https://silicondales.com/tag/canada/" class="tag-cloud-link tag-link-4424 tag-link-position-6" style="font-size: 8pt;" aria-label="Canada (8 items)">Canada</a> <a href="https://silicondales.com/tag/centos/" class="tag-cloud-link tag-link-297 tag-link-position-7" style="font-size: 8.4347826086957pt;" aria-label="CentOS (9 items)">CentOS</a> <a href="https://silicondales.com/tag/checkout/" class="tag-cloud-link tag-link-303 tag-link-position-8" style="font-size: 11.391304347826pt;" aria-label="checkout (21 items)">checkout</a> <a href="https://silicondales.com/tag/crm/" class="tag-cloud-link tag-link-4412 tag-link-position-9" style="font-size: 8.7826086956522pt;" aria-label="CRM (10 items)">CRM</a> <a href="https://silicondales.com/tag/database/" class="tag-cloud-link tag-link-4330 tag-link-position-10" style="font-size: 10pt;" aria-label="Database (14 items)">Database</a> <a href="https://silicondales.com/tag/delivery/" class="tag-cloud-link tag-link-2028 tag-link-position-11" style="font-size: 12.608695652174pt;" aria-label="Delivery (29 items)">Delivery</a> <a href="https://silicondales.com/tag/ec2/" class="tag-cloud-link tag-link-497 tag-link-position-12" style="font-size: 10.695652173913pt;" aria-label="EC2 (17 items)">EC2</a> <a href="https://silicondales.com/tag/email/" class="tag-cloud-link tag-link-511 tag-link-position-13" style="font-size: 11.565217391304pt;" aria-label="Email (22 items)">Email</a> <a href="https://silicondales.com/tag/facebook/" class="tag-cloud-link tag-link-544 tag-link-position-14" style="font-size: 8.7826086956522pt;" aria-label="Facebook (10 items)">Facebook</a> <a href="https://silicondales.com/tag/filter/" class="tag-cloud-link tag-link-4369 tag-link-position-15" style="font-size: 12pt;" aria-label="Filter (25 items)">Filter</a> <a href="https://silicondales.com/tag/gerhard-potgieter/" class="tag-cloud-link tag-link-4437 tag-link-position-16" style="font-size: 9.1304347826087pt;" aria-label="Gerhard Potgieter (11 items)">Gerhard Potgieter</a> <a href="https://silicondales.com/tag/gmail/" class="tag-cloud-link tag-link-661 tag-link-position-17" style="font-size: 10.869565217391pt;" aria-label="Gmail (18 items)">Gmail</a> <a href="https://silicondales.com/tag/gmail-tutorials/" class="tag-cloud-link tag-link-4747 tag-link-position-18" style="font-size: 11.391304347826pt;" aria-label="Gmail tutorials (21 items)">Gmail tutorials</a> <a href="https://silicondales.com/tag/google/" class="tag-cloud-link tag-link-666 tag-link-position-19" style="font-size: 12.347826086957pt;" aria-label="Google (27 items)">Google</a> <a href="https://silicondales.com/tag/google-apps/" class="tag-cloud-link tag-link-668 tag-link-position-20" style="font-size: 10.173913043478pt;" aria-label="Google Apps (15 items)">Google Apps</a> <a href="https://silicondales.com/tag/g-suite/" class="tag-cloud-link tag-link-4657 tag-link-position-21" style="font-size: 8.4347826086957pt;" aria-label="G Suite (9 items)">G Suite</a> <a href="https://silicondales.com/tag/hosting/" class="tag-cloud-link tag-link-2282 tag-link-position-22" style="font-size: 9.3913043478261pt;" aria-label="Hosting (12 items)">Hosting</a> <a href="https://silicondales.com/tag/images/" class="tag-cloud-link tag-link-850 tag-link-position-23" style="font-size: 10.434782608696pt;" aria-label="Images (16 items)">Images</a> <a href="https://silicondales.com/tag/ivan-andreev/" class="tag-cloud-link tag-link-4457 tag-link-position-24" style="font-size: 8.7826086956522pt;" aria-label="Ivan Andreev (10 items)">Ivan Andreev</a> <a href="https://silicondales.com/tag/linux/" class="tag-cloud-link tag-link-996 tag-link-position-25" style="font-size: 9.7391304347826pt;" aria-label="Linux (13 items)">Linux</a> <a href="https://silicondales.com/tag/lucas-stark/" class="tag-cloud-link tag-link-4406 tag-link-position-26" style="font-size: 8pt;" aria-label="Lucas Stark (8 items)">Lucas Stark</a> <a href="https://silicondales.com/tag/mysql/" class="tag-cloud-link tag-link-1133 tag-link-position-27" style="font-size: 10.869565217391pt;" aria-label="MySQL (18 items)">MySQL</a> <a href="https://silicondales.com/tag/payment-gateways/" class="tag-cloud-link tag-link-4379 tag-link-position-28" style="font-size: 17.565217391304pt;" aria-label="Payment Gateways (110 items)">Payment Gateways</a> <a href="https://silicondales.com/tag/paypal/" class="tag-cloud-link tag-link-1248 tag-link-position-29" style="font-size: 9.1304347826087pt;" aria-label="PayPal (11 items)">PayPal</a> <a href="https://silicondales.com/tag/php/" class="tag-cloud-link tag-link-1266 tag-link-position-30" style="font-size: 8.7826086956522pt;" aria-label="PHP (10 items)">PHP</a> <a href="https://silicondales.com/tag/plugins/" class="tag-cloud-link tag-link-1280 tag-link-position-31" style="font-size: 8pt;" aria-label="plugins (8 items)">plugins</a> <a href="https://silicondales.com/tag/reports/" class="tag-cloud-link tag-link-4461 tag-link-position-32" style="font-size: 9.7391304347826pt;" aria-label="Reports (13 items)">Reports</a> <a href="https://silicondales.com/tag/seo/" class="tag-cloud-link tag-link-1469 tag-link-position-33" style="font-size: 9.7391304347826pt;" aria-label="SEO (13 items)">SEO</a> <a href="https://silicondales.com/tag/shipping/" class="tag-cloud-link tag-link-4388 tag-link-position-34" style="font-size: 12.608695652174pt;" aria-label="Shipping (29 items)">Shipping</a> <a href="https://silicondales.com/tag/skyverge/" class="tag-cloud-link tag-link-4381 tag-link-position-35" style="font-size: 14.95652173913pt;" aria-label="SkyVerge (55 items)">SkyVerge</a> <a href="https://silicondales.com/tag/south-africa/" class="tag-cloud-link tag-link-4487 tag-link-position-36" style="font-size: 9.1304347826087pt;" aria-label="South Africa (11 items)">South Africa</a> <a href="https://silicondales.com/tag/staging-environment/" class="tag-cloud-link tag-link-4368 tag-link-position-37" style="font-size: 8.7826086956522pt;" aria-label="Staging Environment (10 items)">Staging Environment</a> <a href="https://silicondales.com/tag/store/" class="tag-cloud-link tag-link-4401 tag-link-position-38" style="font-size: 11.565217391304pt;" aria-label="Store (22 items)">Store</a> <a href="https://silicondales.com/tag/tracking/" class="tag-cloud-link tag-link-4420 tag-link-position-39" style="font-size: 8pt;" aria-label="Tracking (8 items)">Tracking</a> <a href="https://silicondales.com/tag/twitter/" class="tag-cloud-link tag-link-1749 tag-link-position-40" style="font-size: 8.7826086956522pt;" aria-label="Twitter (10 items)">Twitter</a> <a href="https://silicondales.com/tag/uk/" class="tag-cloud-link tag-link-1756 tag-link-position-41" style="font-size: 10.869565217391pt;" aria-label="UK (18 items)">UK</a> <a href="https://silicondales.com/tag/united-states/" class="tag-cloud-link tag-link-4380 tag-link-position-42" style="font-size: 13.391304347826pt;" aria-label="United States (36 items)">United States</a> <a href="https://silicondales.com/tag/woocommerce/" class="tag-cloud-link tag-link-1915 tag-link-position-43" style="font-size: 21.565217391304pt;" aria-label="Woocommerce (326 items)">Woocommerce</a> <a href="https://silicondales.com/tag/wordpress/" class="tag-cloud-link tag-link-2286 tag-link-position-44" style="font-size: 22pt;" aria-label="WordPress (360 items)">WordPress</a> <a href="https://silicondales.com/tag/wp/" class="tag-cloud-link tag-link-1929 tag-link-position-45" style="font-size: 8pt;" aria-label="WP (8 items)">WP</a></div></section></aside></div><div class="pre-footer-section"><h2>Get in touch</h2><p>What does your business need? Make it happen.</p> <a href="https://silicondales.com/about-us/contact-us/" title="Contact Us"><button type="button">Contact Us</button></a></div><footer id="colophon" class="site-footer"><div class="footer_menu_class"><ul id="menu-footer-menu" class="menu"><li id="menu-item-48181" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-48181"><a href="https://silicondales.com/">Home</a></li><li id="menu-item-49155" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49155"><a href="https://silicondales.com/about-us/">About Us</a></li><li id="menu-item-50815" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50815"><a href="https://silicondales.com/careers/">Careers</a></li><li id="menu-item-55603" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55603"><a href="https://silicondales.com/legal/">Legal</a></li><li id="menu-item-48185" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48185"><a href="https://silicondales.com/expertise/">Expertise</a></li><li id="menu-item-51194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51194"><a href="https://silicondales.com/magazine/">Magazine</a></li><li id="menu-item-51477" class="contact-us menu-item menu-item-type-post_type menu-item-object-page menu-item-51477"><a href="https://silicondales.com/about-us/contact-us/">Contact Us</a></li></ul></div><div class="site-info"><p>&copy;2017 Silicon Dales Ltd. All Rights Reserved.</p><p>Silicon Dales Ltd is registered in England & Wales. Company number: 7324510. Directors: Robin J.E. Scott, Jonathan M.G. Farrington, Linda Scott and Steven Haywood. VAT Number GB 111 682 442. Registered Office: Silicon Dales Ltd, Lowry House, 17 Marble Street, Manchester, M2 3AW.</p></div></footer></div><div class="mobmenu-overlay"></div><div class="mob-menu-header-holder mobmenu" ><div  class="mobmenul-container"><a href="#" class="mobmenu-left-bt"><i class="mob-icon-menu mob-menu-icon"></i><i class="mob-icon-cancel mob-cancel-button"></i></a></div><div class="mob-menu-logo-holder"><a href="https://silicondales.com" class="headertext"><span>Silicon Dales</span></a></div><div  class="mobmenur-container"><a href="#" class="mobmenu-right-bt"><i class="mob-icon-menu mob-menu-icon"></i><i class="mob-icon-cancel mob-cancel-button"></i></a></div></div><div class="mob-menu-left-panel mobmenu  "><div class="mobmenu_content"><div class="menu-footer-menu-container"><ul id="mobmenuleft"><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-48181"><a href="https://silicondales.com/" class="">Home</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49155"><a href="https://silicondales.com/about-us/" class="">About Us</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50815"><a href="https://silicondales.com/careers/" class="">Careers</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55603"><a href="https://silicondales.com/legal/" class="">Legal</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48185"><a href="https://silicondales.com/expertise/" class="">Expertise</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51194"><a href="https://silicondales.com/magazine/" class="">Magazine</a></li><li  class="contact-us menu-item menu-item-type-post_type menu-item-object-page menu-item-51477"><a href="https://silicondales.com/about-us/contact-us/" class="">Contact Us</a></li></ul></div></div><div class="mob-menu-left-bg-holder"></div></div><div class="mob-menu-right-panel mobmenu  "><div class="mobmenu_content"><div class="menu-footer-menu-container"><ul id="mobmenuright"><li  class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-48181"><a href="https://silicondales.com/" class="">Home</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-49155"><a href="https://silicondales.com/about-us/" class="">About Us</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-50815"><a href="https://silicondales.com/careers/" class="">Careers</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-55603"><a href="https://silicondales.com/legal/" class="">Legal</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-48185"><a href="https://silicondales.com/expertise/" class="">Expertise</a></li><li  class="menu-item menu-item-type-post_type menu-item-object-page menu-item-51194"><a href="https://silicondales.com/magazine/" class="">Magazine</a></li><li  class="contact-us menu-item menu-item-type-post_type menu-item-object-page menu-item-51477"><a href="https://silicondales.com/about-us/contact-us/" class="">Contact Us</a></li></ul></div></div><div class="mob-menu-right-bg-holder"></div></div> <script type='text/javascript'>var ezTOC = {"smooth_scroll":"1","visibility_hide_by_default":"","width":"auto","scroll_offset":"130"};</script> <script>(function(w, d){
	var b = d.getElementsByTagName("body")[0];
	var s = d.createElement("script"); s.async = true;
	var v = !("IntersectionObserver" in w) ? "8.5.2" : "10.3.5";
	s.src = "https://silicondales.com/wp-content/plugins/wp-rocket/inc/front/js/lazyload-" + v + ".min.js";
	w.lazyLoadOptions = {
		elements_selector: "img, iframe",
		data_src: "lazy-src",
		data_srcset: "lazy-srcset",
		skip_invisible: false,
		class_loading: "lazyloading",
		class_loaded: "lazyloaded",
		threshold: 300,
		callback_load: function(element) {
			if ( element.tagName === "IFRAME" && element.dataset.rocketLazyload == "fitvidscompatible" ) {
				if (element.classList.contains("lazyloaded") ) {
					if (typeof window.jQuery != "undefined") {
						if (jQuery.fn.fitVids) {
							jQuery(element).parent().fitVids();
						}
					}
				}
			}
		}
	}; // Your options here. See "recipes" for more information about async.
	b.appendChild(s);
}(window, document));

// Listen to the Initialized event
window.addEventListener('LazyLoad::Initialized', function (e) {
    // Get the instance and puts it in the lazyLoadInstance variable
	var lazyLoadInstance = e.detail.instance;

	var observer = new MutationObserver(function(mutations) {
		mutations.forEach(function(mutation) {
			lazyLoadInstance.update();
		} );
	} );
	
	var b      = document.getElementsByTagName("body")[0];
	var config = { childList: true, subtree: true };
	
	observer.observe(b, config);
}, false);</script> <script type="text/javascript" defer src="https://silicondales.com/wp-content/cache/autoptimize/js/autoptimize_e92240e1f608bbe3118cf4431a35b835.js"></script></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1517850784 -->